Buy Online or Call 1-888-425-6739 | 8:30 AM - 10 PM EST | 7 Days a Week

Error Message: FLIR Cloud Client software - Older version error

If you are trying to install FLIR Cloud Client software on your computer, you may get a message that says You are currently running an older version of FLIR Cloud, please uninstall the older version to continue. This error message can occur if your computer has an older version of FLIR Cloud Client software currently installed. It could also be caused by other third-party camera software programs conflicting with the FLIR Cloud Client software installation.

The following instructions require you to access your system using the FLIR Cloud Client software and a PC / Mac.

To troubleshoot the older version is running error message:

  1. Uninstall all versions of the FLIR Cloud Client software from your computer.
  2. Uninstall any third-party camera system programs from your computer.
  3. Restart your computer.
  4. Download and install the latest FLIR Cloud Client software. Click here for downloads and documentation for your product.
  5. After installing the FLIR Cloud Client software, re-install any third-party camera system programs.